Probleme mit Suche rechts oben

Benutzeravatar
darock
TReam Team
TReam Team
Beiträge: 4057
Registriert: 10.05.2009, 23:00
Wohnort: Wien
Hat sich bedankt: 27 Mal
Danksagung erhalten: 45 Mal
Kontaktdaten:

Probleme mit Suche rechts oben

#1

Beitrag von darock » 06.10.2018, 09:01

Guten Morgen,

Wenn ich versuche etwas zu suchen steht "Du bist nicht berechtigt die Suche zu verwenden"

????

Bernhard

Benutzeravatar
Berthold
TReam Team
TReam Team
Beiträge: 786
Registriert: 12.06.2013, 23:00
Wohnort: Bergisch Gladbach
Hat sich bedankt: 11 Mal
Danksagung erhalten: 164 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#2

Beitrag von Berthold » 06.10.2018, 13:57

Kann ich nicht nachvollziehen. Klappt auch mit dem Testuser-Account.

Hat sonst noch jemand das Problem und kann nähere Infos liefern?

Gruß Berthold

Benutzeravatar
darock
TReam Team
TReam Team
Beiträge: 4057
Registriert: 10.05.2009, 23:00
Wohnort: Wien
Hat sich bedankt: 27 Mal
Danksagung erhalten: 45 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#3

Beitrag von darock » 06.10.2018, 14:03

Ich konnte das Problem auf die Anmeldung eingrenzen. Das dauerhafte Anmelden funktioniert bei mir immer noch nicht, weswegen ich immer ausgeloggt bin.

Komme ich auf das Portal, bin ich ausgeloggt, also logge ich ein. Rechts oben steht mein Benutzername. Benutze ich dann gleich die Suche kommt der Fehler und in dem Suchen Fenster steht rechts oben wieder "Anmelden", ergo bin ich für das Forum nicht angemeldet was dann auch den Fehler erklärt.

Zusätzlich dazu habe ich auch immer wieder mal Probleme beim Anmelden. Benutze ich die Anmeldung direkt am Portal so passiert es ab und zu, dass die Seite nach dem Anmelden nicht geladen werden kann. Ich muss dann noch einmal von Vorne anfangen, dann geht es meist.

Bernhard

Benutzeravatar
tr_tom
Institution
Institution
Beiträge: 5132
Registriert: 30.04.2009, 23:00
Wohnort: Duisburg TR4A IRS '65
Hat sich bedankt: 33 Mal
Danksagung erhalten: 69 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#4

Beitrag von tr_tom » 07.10.2018, 07:14

Hallo Bernhard,

hast du schon versucht, alle Cookies in deinem Browser zu löschen?

Oder mal einen anderen Browser probieren...

Gruss
Thomas
» Carpe diem - nutze den Tag... «

Kamphausen
Profi
Profi
Beiträge: 1880
Registriert: 26.10.2015, 22:05
Wohnort: Essen
Hat sich bedankt: 33 Mal
Danksagung erhalten: 102 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#5

Beitrag von Kamphausen » 07.10.2018, 08:57

Das Forum muß mit allen Browsern funktionieren...nicht nur mit Safari...
Ich hatte das Problem mit dem Firefox auch..seit drei Tagen ist es weg...

Im Persönlichen Bereich mal alle "gespeicherten Anmeldungen" löschen, im Browser alle Cookies löschen und dann noch mal von vorn
Hat bei mir geholfen...

Trotzdem liegt es definitiv am Forum, da das Problem immer wieder und nur hier auftritt...alle anderen PHPBB-based Foren, die ich besuche, bereiten das Problem nicht...

Evtl. sollte Berthold mal den Cache löschen und die Setting für die Cookies anpassen...

Und warum ist überhaupt die Suche für Besucher verboten?!?!? :kopfklatsch

Benutzeravatar
BayernTR7
ORGA-Team Vorarlberg
Beiträge: 801
Registriert: 10.11.2007, 00:00
Wohnort: Mainburg
Hat sich bedankt: 14 Mal
Danksagung erhalten: 16 Mal

Re: Probleme mit Suche rechts oben

#6

Beitrag von BayernTR7 » 07.10.2018, 09:46

Die Problematik kann auch an den eigenen Lesezeichen, Favoriten am Rechner liegen. Das habe ich gerade bei mir festgestellt (Firefox 62.0.3). Tippe ich tr-freunde.de ein und achte darauf, dass nicht ergänzt wird, dann bleibt mein Login bestehen. Das ist auch der Fall wenn ich auf der Seite rechts oben das TR-Freunde-Logo anklicke. Lasse ich die Ergänzung zu u.a. auch mit dem Anhang zum Portal, dann bin ich plötzlich nicht mehr eingelogt auch mit Fehlermeldung bei der Suche. Klicke ich wieder auf das TR-Freunde-Logo bin ich nach dem Laden desr Hauptseite wieder eingelogt und auch die Suche geht. Alles im übrigen nach dem Löschen des Caches und der Logindaten.

Anscheinend gibt es auf dem TR-Freunde- Server irgendwelche alte Seiten, die zu diesem Effekt führen und zu denen man über alte Lesezeichen gelangt. Vielleicht kann das ja Berthold mal prüfen. Ich habe mir im FIrefox jetzt den Direktlink mit dem reinen www.tr-freun.de angelegt. Damit scheint alles zu funktionieren. Meine alten Lesezeichen schmeisse ich aber ungern raus,


Auf jeden Fall vielen Dank an Berthold und all die anderen, die mit helfen das Forum in Schuss zu halten und unsere Nörgeleien, Verzeihung Anregungen geduldig hinnehmen und die Fehler auch beseitigen.

:wave:
Mit triumphalen Grüssen aus der Holledau

Peter

Tr(i)umph ist die Seele des Spiels

Benutzeravatar
darock
TReam Team
TReam Team
Beiträge: 4057
Registriert: 10.05.2009, 23:00
Wohnort: Wien
Hat sich bedankt: 27 Mal
Danksagung erhalten: 45 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#7

Beitrag von darock » 07.10.2018, 09:47

Kann bitte irgendwer von euch mit Admin rechten die gespeicherten Anmeldungen von mir löschen? Habe echt keine Lust eine Stunde herumzuklicken.

Cookies und Cache löschen habe ich schon mehrfach versucht. Auch sind meine Cookie Einstellungen völlig normal und nicht restriktiv.

Und ja, es ist bei keinem anderen Forum so wie hier. Es hat ja ich einwandfrei funktioniert als die Einstellungen so waren, dass die Anmeldung im Marktplatz nicht ging.

Bernhard

Kamphausen
Profi
Profi
Beiträge: 1880
Registriert: 26.10.2015, 22:05
Wohnort: Essen
Hat sich bedankt: 33 Mal
Danksagung erhalten: 102 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#8

Beitrag von Kamphausen » 07.10.2018, 11:17

5 Sekunden:

klick auf den link:
https://tr-freun.de/phpBB3/ucp.php?i=uc ... login_keys

dann ganz unten auf "alle markieren" und danach auf "markierte löschen"....


Peter

Benutzeravatar
darock
TReam Team
TReam Team
Beiträge: 4057
Registriert: 10.05.2009, 23:00
Wohnort: Wien
Hat sich bedankt: 27 Mal
Danksagung erhalten: 45 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#9

Beitrag von darock » 07.10.2018, 12:13

Danke!

Das alle markieren ist mir irgendwie verborgen geblieben. :D

Na mal sehen wie das jetzt funktioniert

Bernhard

Kamphausen
Profi
Profi
Beiträge: 1880
Registriert: 26.10.2015, 22:05
Wohnort: Essen
Hat sich bedankt: 33 Mal
Danksagung erhalten: 102 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#10

Beitrag von Kamphausen » 07.10.2018, 16:45

Warum kommen solche Tips nicht mal von den Herren Moderatoren/Administratoren? :-?

Naja... 8-O

Grüße vom schwarzen Schaf...

Benutzeravatar
dakwo74
gehört zum Inventar
gehört zum Inventar
Beiträge: 697
Registriert: 15.12.2014, 00:00
Wohnort: 88069 Tettnang
Hat sich bedankt: 16 Mal
Danksagung erhalten: 42 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#11

Beitrag von dakwo74 » 08.10.2018, 06:02

Hallo Berthold,
die Suche Funktion erscheint bei mir nur wenn ich angemeldet bin.
Ich dachte, das ist so gewollt, da es bei den anderen Forums auch so funktioniert.
Grüße
Jochem
Fliegender Holländer am Bodensee fährt:
TR6 - 1973 - 56/11 - CF1xxxxUO - J-OD - Kent 280° - Phoenix - EMU Black - 205/70 auf 7x15

Benutzeravatar
Berthold
TReam Team
TReam Team
Beiträge: 786
Registriert: 12.06.2013, 23:00
Wohnort: Bergisch Gladbach
Hat sich bedankt: 11 Mal
Danksagung erhalten: 164 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#12

Beitrag von Berthold » 08.10.2018, 07:11

Ich möchte hier nun auch noch etwas zur Aufklärung beitragen.
darock hat geschrieben:
06.10.2018, 14:03
Ich konnte das Problem auf die Anmeldung eingrenzen. Das dauerhafte Anmelden funktioniert bei mir immer noch nicht, weswegen ich immer ausgeloggt bin.
Das Thema hatten wir schon leider schon mehrfach. In diversen Foren existieren Lösungsvorschläge, die aber nicht mit der Bridge zu unserer Bildergalerie kompatibel sind. Auch das könnte man vermutlich lösen, selbst wenn dann wieder von Bastelforum die Rede ist. Dummerweise ist dieses Verhalten so weit mir bekannt nicht reproduzierbar. Die Wirksamkeit einer "Korrektur" kann also nicht vorab getestet werden. Bei meinem letzten Versuch, der auf meinem System zu einer Verbesserung geführt hat, hatten plötzlich mehr User ein Problem damit.
Seitens der phpBB Entwickler hat dieses Thema keinerlei Relevanz, da aus Sicherheitsgründen eine dauerhafte Anmeldung nicht erwünscht ist. Es wurde sogar bereits darüber diskutiert die Funktion in zukünftigen Versionen nicht mehr zu unterstützen. Wenn es nicht gelingt dieses Verhalten eindeutig reproduzierbar zu machen werden wir wohl damit leben müssen.
darock hat geschrieben:
06.10.2018, 14:03
Komme ich auf das Portal, bin ich ausgeloggt, also logge ich ein. Rechts oben steht mein Benutzername. Benutze ich dann gleich die Suche kommt der Fehler und in dem Suchen Fenster steht rechts oben wieder "Anmelden", ergo bin ich für das Forum nicht angemeldet was dann auch den Fehler erklärt.
Das kann ich mit mehreren Browsern und verschiedenen Useraccounts nicht nachvollziehen. Mir sind auch sonst keine diesbezüglichen Fehlermeldungen bekannt.
darock hat geschrieben:
06.10.2018, 14:03
Zusätzlich dazu habe ich auch immer wieder mal Probleme beim Anmelden. Benutze ich die Anmeldung direkt am Portal so passiert es ab und zu, dass die Seite nach dem Anmelden nicht geladen werden kann. Ich muss dann noch einmal von Vorne
Das kenne ich so auch nicht. Bei mir kommt es in ganz seltenen Fällen (ca. einmal in Jahr) vor, dass die Anmeldung trotz richtiger Daten gar nicht funktioniert. Allerdings auch nicht beim zweiten oder weiteren Versuchen. In diesen Fällen enthält der TR-Freun.de Cookie keine Daten. Zur Abhilfe sind Cookies und Browsercache zu löschen. Anschließend funktioniert die Anmeldung wieder.

Kamphausen hat geschrieben:
07.10.2018, 08:57
Das Forum muß mit allen Browsern funktionieren...nicht nur mit Safari...
Hat irgendjemand was von Safari geschrieben??? Ich nicht.
Nur mal als Hinweis: Ob Du angemeldet bist oder nicht wird auf dem Server und nicht im Browser entschieden. Auf dem Server wiederum läuft nur eine PHP Version. Da gibt es keine Unterscheidung zwischen den Browsern.

Kamphausen hat geschrieben:
07.10.2018, 08:57
Im Persönlichen Bereich mal alle "gespeicherten Anmeldungen" löschen, im Browser alle Cookies löschen und dann noch mal von vorn
Hat bei mir geholfen...
Das hat bisher bei allen geholfen und ist auch schon beschrieben worden.

Kamphausen hat geschrieben:
07.10.2018, 08:57
Trotzdem liegt es definitiv am Forum, da das Problem immer wieder und nur hier auftritt...alle anderen PHPBB-based Foren, die ich besuche, bereiten das Problem nicht...
Mit dem definitiv wäre ich etwas vorsichtig. Warum sonst sollte es sowohl im deutschen als auch im englischen Forum seit Jahren entsprechende Nachfragen geben, wenn das Problem doch garnicht existiert??? Und im Gegensatz zu dir kenne ich auch andere Foren mit diesem "Problem".

Kamphausen hat geschrieben:
07.10.2018, 08:57
Und warum ist überhaupt die Suche für Besucher verboten?!?!? :kopfklatsch
Weil hier vor Kurzem angemerkt wurde, dass Gäste zu viele Rechte haben. Daraufhin habe ich die Rechte der Gäste etwas eingeschränkt.

dakwo74 hat geschrieben:
08.10.2018, 06:02
Ich dachte, das ist so gewollt, da es bei den anderen Forums auch so funktioniert.
Peter sieht das gänzlich anders. Ist mal wieder so ein Punkt, wo man es nicht jedem recht machen kann.

BayernTR7 hat geschrieben:
07.10.2018, 09:46
Die Problematik kann auch an den eigenen Lesezeichen, Favoriten am Rechner liegen. Das habe ich gerade bei mir festgestellt (Firefox 62.0.3). Tippe ich tr-freunde.de ein und achte darauf, dass nicht ergänzt wird, dann bleibt mein Login bestehen. Das ist auch der Fall wenn ich auf der Seite rechts oben das TR-Freunde-Logo anklicke. Lasse ich die Ergänzung zu u.a. auch mit dem Anhang zum Portal, dann bin ich plötzlich nicht mehr eingelogt auch mit Fehlermeldung bei der Suche. Klicke ich wieder auf das TR-Freunde-Logo bin ich nach dem Laden desr Hauptseite wieder eingelogt und auch die Suche geht. Alles im übrigen nach dem Löschen des Caches und der Logindaten.
Das ist mal ein interessanter Hinweis. Bei mir erscheint wenn ich tr-f eingebe tr-freun.de/ ohne weitere Ergänzungen. Ebenfalls Firefox 62.0.3. Die Anmeldung bleibt auch bei Verwendung eines Lesezeichens erhalten.
Mich würde mal interessieren, wie die automatisch ergänzte Webadresse lautet, nach der die Anmeldung verschwunden ist. Gab es da vor längerer Zeit nicht mal Lesezeichen mit SessionID?

Nach dem langen Text die Fakten als Zusammenfassung:
- Aktuell ist die Suche nur für angemeldete User sicht- und damit nutzbar. Kann auch wieder geändert werden.
- Die bekannten Probleme mit der dauerhaften Anmeldung können durch löschen der TR-Freun.de Cookies, des Browsercache und der gespeicherten Anmeldungen gelöst werden. Leider keine dauerhafte Lösung in Sicht.

Gruß Berthold

Benutzeravatar
BayernTR7
ORGA-Team Vorarlberg
Beiträge: 801
Registriert: 10.11.2007, 00:00
Wohnort: Mainburg
Hat sich bedankt: 14 Mal
Danksagung erhalten: 16 Mal

Re: Probleme mit Suche rechts oben

#13

Beitrag von BayernTR7 » 08.10.2018, 08:30

Guten Morgen Berthold,
bei mir hängt es u.a. wohl mit meiner Startseite in FIrefox (sowohl unter Ubuntu als auch WIN 10) zusammen wie auch mit den o.g. Lesezeichen.
Benutze ich zum Laden das "reine" www.tr.freun.de, dann bin ich eingelogt. Benutze ich die Adresse die in der Browserseite oben gezeigt wird
http ://tr-freun.de/phpBB3/app.php/portal
zum laden (ohne das eingefügte Leerzeichen) ist mein Login erst mal weg. Nehme ich dann wieder das reine tr-freun.de wird es wieder angezeigt.

Die Adresse in der Browserzeile wird von den verschiedenen Browsern u.a. auch dann genutzt wenn man die Funktion "Diese Seite als Starrtseite verwenden" benutzt!!!! und auch bei den Favoriten. Das heisst das wird auch bei der Ergänzungsfunktion eingetragen.

Ich habe jetzt für den Start in der Menüzeile und für die Startseite das per Hand geändert also www.tr.freun.de eingetragen. Das hat jetzt erst mal den gewünschten Erfolg gebracht. Ich werde das mal beobachten und verschiedenes ausprobieren. (Hm!!! Die Zitatfunktion, hat auch so Ihre Eigenheiten???)
Mit triumphalen Grüssen aus der Holledau

Peter

Tr(i)umph ist die Seele des Spiels

Benutzeravatar
Berthold
TReam Team
TReam Team
Beiträge: 786
Registriert: 12.06.2013, 23:00
Wohnort: Bergisch Gladbach
Hat sich bedankt: 11 Mal
Danksagung erhalten: 164 Mal
Kontaktdaten:

Re: Probleme mit Suche rechts oben

#14

Beitrag von Berthold » 08.10.2018, 09:29

BayernTR7 hat geschrieben:
08.10.2018, 08:30
Benutze ich zum Laden das "reine" www.tr.freun.de, dann bin ich eingelogt.
Das www ist nicht notwendig. Es reicht tr-freun.de.
BayernTR7 hat geschrieben:
08.10.2018, 08:30
http ://tr-freun.de/phpBB3/app.php/portal
Hier müsste https:// statt http:// verwendet werden. Es handelt sich wohl um alte Lesezeichen die angelegt wurden, bevor wir auf https:// umgestellt hatten. Es erfolgt zwar eine automatische Anpassung, aber eventuell geht dabei etwas schief.

Versuch doch mal die Lesezeichen so zu ändern, dass sie mit https://tr-freun.de/... beginnen. Und dann noch mal Cookies, Browsercache, gespeicherte Anmeldungen löschen.

Gruß Berthold

Benutzeravatar
BayernTR7
ORGA-Team Vorarlberg
Beiträge: 801
Registriert: 10.11.2007, 00:00
Wohnort: Mainburg
Hat sich bedankt: 14 Mal
Danksagung erhalten: 16 Mal

Re: Probleme mit Suche rechts oben

#15

Beitrag von BayernTR7 » 08.10.2018, 10:45

Hallo Berthold,

den zitierten Link hatte ich aus der Browserzeile der geladenen Seite vorhin kopiert!!!
Lässt sich momentan nicht reproduzieren.

Das www. hatte ich nur zur Verdeutlichung eingefügt. s´ist schon klar dass man das nicht mitschreiben muss.

Ich werde mal noch das eine oder andere ausprobieren. :party1
Mit triumphalen Grüssen aus der Holledau

Peter

Tr(i)umph ist die Seele des Spiels

Antworten

Zurück zu „Rund um den Internetauftritt“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste